ALS-voorwaarden in Excel

Je kunt 1001 dingen doen met Excel. Het is nu eenmaal marktleider op het gebied van lijstjes en rekenen. Toch gebruiken veel mensen het programma niet optimaal. Ken jij bijvoorbeeld de ALS-voorwaarden in Excel? Wij laten een paar toepassingsmogelijkheden zien.

Zo gebruik je ALS-voorwaarden in Excel

Het concept van ALS

Belangrijk om te weten is dat je met een ALS-commando drie opdrachten in één formule zet, volgens het principe =ALS(VERGELIJKING;DAN;ANDERS). De eerste opdracht is een vergelijking, die tweede en derde opdracht kan een formule zijn, een getal of tekst. Dat schept ontzettend veel mogelijkheden, waarvan we je er graag een paar laten zien. Zoals bij alle formules in Excel, moet je ook deze formule beginnen met het symbool =. De opdrachten worden gescheiden met een puntkomma ‘;’ en de formule wordt afgesloten met een haakje ‘)’.

Dubbelen zoeken

Stel: je gaat met vrienden of familie op vakantie met de caravan. Samen eropuit trekken is erg gezellig, zeker ’s avonds. Maar: wie neemt wat nu precies mee? Door in Excel een lijst te maken en te sorteren (Gegevens>Sorteren) kan je een alfabetische lijst maken. Nu kan je de cellen gaan vergelijken. Vergelijk bijvoorbeeld cel A3 met A2. Is die hetzelfde, dan wil je het woord ‘Dubbel’ in kolom B tonen. Is die niet gelijk, dan mag die cel leeg blijven. Als je de formule uitspreekt, is dat ‘Als A3 = A2, toon dan Dubbel, anders doe niets’. De formule in cel B3 wordt =ALS(A3=A2;”Dubbel”;””). Die formule kan je naar onder door kopiëren.

Zoeken naar dubbelen was nooit zo eenvoudig.

Uitgavenboekje

Laten we eens kijken naar het uitgavenboekje, iets waar veel mensen Excel voor gebruiken. In kolom A staat de omschrijving, in kolom B het bedrag. Dat is positief (inkomsten) of negatief (uitgaven). In kolom C en D maken we daar een splitsing in. In kolom C komen de bedragen uit kolom B die < 0 zijn. In kolom D komen de bedragen die > 0 zijn. De formule van cel C4 is =ALS(B4<0;B4*-1;””). De formule van cel D4 is =ALS(B4>0;B4;””).

Een goed overzicht is onbetaalbaar.

ALS-in-ALS

Het is misschien een pro-tip, maar je kan ALS-formules ook in elkaar verweven. Dat noemen we ook wel geneste ALS-functies. Werk daarbij met > vergelijkingen van hoog naar laag, en met < vergelijkingen van laag naar hoog. Stel: je werkt met verkopers op commissie, die een bonus krijgen over hun verkopen. Deze bonus begint bij 5.000 euro verkoop en stijgt met 2,5% voor elke 1.000 euro extra verkoop. De formule voor cel B2 is dan: =ALS(A2>9000;20;ALS(A2>8000;17,5;ALS(A2>7000;15;ALS(A2>6000;12,5;ALS(A2>5000;10;””))))). Zie hoe we van hoog naar laag werken, en dat op het einde van de formule iedere ALS-variabele wordt afgesloten met een eigen haakje.

Een variabele formule op basis van de beginwaarde.